Skip to content

Commit

Permalink
dotnet-host and 8/9 changes
Browse files Browse the repository at this point in the history
  • Loading branch information
sec committed Nov 23, 2024
1 parent c348a54 commit 785055f
Show file tree
Hide file tree
Showing 7 changed files with 63 additions and 12 deletions.
42 changes: 42 additions & 0 deletions lang/dotnet-host/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
PORTNAME= dotnet-host
DISTVERSION= 9.0.0
GH_ACCOUNT= dotnet
GH_PROJECT= runtime
DISTVERSIONPREFIX= v
CATEGORIES= lang devel

MAINTAINER= arrowd@FreeBSD.org
COMMENT= Open-source developer platform and a cross-platform runtime for cloud, mobile, desktop, and IoT apps. Contains dotnet host binary only.
WWW= https://dot.net

LICENSE= MIT

BUILD_DEPENDS= bash:shells/bash \
cmake:devel/cmake-core

USES= llvm:noexport ssl

USE_GITHUB= yes

DOTNET_ARCH= ${ARCH:S|amd64|x64|:C|aarch64|arm64|}

PLIST_FILES= bin/dotnet \
dotnet/LICENSE.TXT \
dotnet/THIRD-PARTY-NOTICES.TXT \
dotnet/dotnet

do-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} src/native/corehost/build.sh -ci -c Release

do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/dotnet

cp ${WRKSRC}/artifacts/bin/freebsd-${DOTNET_ARCH}.Release/corehost/dotnet \
${WRKSRC}/LICENSE.TXT \
${WRKSRC}/THIRD-PARTY-NOTICES.TXT \
${STAGEDIR}${PREFIX}/dotnet/

${ELFCTL} -e +noaslr ${STAGEDIR}${PREFIX}/dotnet/dotnet
${RLN} ${STAGEDIR}${PREFIX}/dotnet/dotnet ${STAGEDIR}${PREFIX}/bin/dotnet

.include <bsd.port.mk>
3 changes: 3 additions & 0 deletions lang/dotnet-host/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
TIMESTAMP = 1732389764
SHA256 (dotnet-runtime-v9.0.0_GH0.tar.gz) = 32755d528ead386762fb9da054249f6151ac78ef6a92f437044838cd0ab00def
SIZE (dotnet-runtime-v9.0.0_GH0.tar.gz) = 89257555
4 changes: 4 additions & 0 deletions lang/dotnet-host/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,4 @@
.NET is an open source developer platform, created by Microsoft, for building
many different types of applications. It provides a standard set of base class
libraries and APIs that are common to all .NET applications. .NET apps can be
written in such languages as C#, F#, or Visual Basic.
6 changes: 3 additions & 3 deletions lang/dotnet/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -27,7 +27,8 @@ LIB_DEPENDS= libbrotlienc.so:archivers/brotli \
libicuuc.so:devel/icu \
libinotify.so:devel/libinotify \
libunwind.so:devel/libunwind
RUN_DEPENDS= terminfo-db>0:misc/terminfo-db
RUN_DEPENDS= terminfo-db>0:misc/terminfo-db \
${LOCALBASE}/dotnet/dotnet:lang/dotnet-host

USES= autoreconf:build gssapi:mit llvm:noexport pkgconfig \
python:build,3.9+ shebangfix ssl
Expand Down Expand Up @@ -100,13 +101,12 @@ do-build:
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/dotnet
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${WRKSRC}/artifacts/assets/Release/${SDK_DISTNAME}${EXTRACT_SUFX} -C ${STAGEDIR}${PREFIX}/dotnet ${EXTRACT_AFTER_ARGS}
${ELFCTL} -e +noaslr ${STAGEDIR}${PREFIX}/dotnet/dotnet

${STRIP_CMD} ${STAGEDIR}${PREFIX}/dotnet/dotnet
${STRIP_CMD} ${STAGEDIR}${PREFIX}/dotnet/sdk/${SDKVERSION}/AppHostTemplate/apphost
${STRIP_CMD} ${STAGEDIR}${PREFIX}/dotnet/packs/Microsoft.NETCore.App.Host.${SDK_RID}/${DISTVERSION}/runtimes/${SDK_RID}/native/apphost
${STRIP_CMD} ${STAGEDIR}${PREFIX}/dotnet/packs/Microsoft.NETCore.App.Host.${SDK_RID}/${DISTVERSION}/runtimes/${SDK_RID}/native/singlefilehost
${FIND} ${STAGEDIR}${PREFIX}/dotnet -name "*.so" -exec ${STRIP_CMD} -s "{}" ";"
${FIND} ${WRKSRC}/artifacts/packages/Release -name "*freebsd*.nupkg" -exec cp "{}" ${STAGEDIR}${PREFIX}/dotnet/library-packs/ ";"

${RLN} ${STAGEDIR}${PREFIX}/dotnet/dotnet ${STAGEDIR}${PREFIX}/bin/dotnet

Expand Down
13 changes: 9 additions & 4 deletions lang/dotnet/pkg-plist
Original file line number Diff line number Diff line change
@@ -1,10 +1,15 @@
bin/dotnet
dotnet/LICENSE.txt
dotnet/ThirdPartyNotices.txt
dotnet/dotnet
dotnet/host/fxr/%%FULL_DOTNETVERSION%%/libhostfxr.so
dotnet/library-packs/Microsoft.DotNet.ILCompiler.%%FULL_DOTNETVERSION%%.nupkg
dotnet/library-packs/Microsoft.NET.ILLink.Tasks.%%FULL_DOTNETVERSION%%.nupkg
dotnet/library-packs/Microsoft.AspNetCore.App.Runtime.%%SDK_RID%%.%%FULL_DOTNETVERSION%%.nupkg
dotnet/library-packs/Microsoft.NETCore.App.Crossgen2.%%SDK_RID%%.%%FULL_DOTNETVERSION%%.nupkg
dotnet/library-packs/Microsoft.NETCore.App.Host.%%SDK_RID%%.%%FULL_DOTNETVERSION%%.nupkg
dotnet/library-packs/Microsoft.NETCore.App.Runtime.%%SDK_RID%%.%%FULL_DOTNETVERSION%%.nupkg
dotnet/library-packs/runtime.%%SDK_RID%%.Microsoft.DotNet.ILCompiler.%%FULL_DOTNETVERSION%%.nupkg
dotnet/library-packs/runtime.%%SDK_RID%%.Microsoft.NETCore.DotNetAppHost.%%FULL_DOTNETVERSION%%.nupkg
dotnet/library-packs/runtime.%%SDK_RID%%.Microsoft.NETCore.ILAsm.%%FULL_DOTNETVERSION%%.nupkg
dotnet/library-packs/runtime.%%SDK_RID%%.Microsoft.NETCore.ILDAsm.%%FULL_DOTNETVERSION%%.nupkg
dotnet/library-packs/runtime.%%SDK_RID%%.Microsoft.NETCore.TestHost.%%FULL_DOTNETVERSION%%-rtm.24528.9.nupkg
dotnet/metadata/workloads/%%SDKVERSION%%/userlocal
dotnet/packs/Microsoft.AspNetCore.App.Ref/%%FULL_DOTNETVERSION%%/analyzers/dotnet/cs/Microsoft.AspNetCore.App.Analyzers.dll
dotnet/packs/Microsoft.AspNetCore.App.Ref/%%FULL_DOTNETVERSION%%/analyzers/dotnet/cs/Microsoft.AspNetCore.App.CodeFixes.dll
Expand Down
3 changes: 2 additions & 1 deletion lang/dotnet8/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -27,7 +27,8 @@ BUILD_DEPENDS= bash:shells/bash \
LIB_DEPENDS= libicuuc.so:devel/icu \
libinotify.so:devel/libinotify \
libunwind.so:devel/libunwind
RUN_DEPENDS= terminfo-db>0:misc/terminfo-db
RUN_DEPENDS= terminfo-db>0:misc/terminfo-db \
${LOCALBASE}/dotnet/dotnet:lang/dotnet-host

USES= autoreconf:build gssapi:mit llvm:noexport nodejs pkgconfig \
python:build,3.9+ shebangfix ssl
Expand Down
4 changes: 0 additions & 4 deletions lang/dotnet8/pkg-plist
Original file line number Diff line number Diff line change
@@ -1,7 +1,3 @@
bin/dotnet
dotnet/LICENSE.txt
dotnet/ThirdPartyNotices.txt
dotnet/dotnet
dotnet/host/fxr/%%FULL_DOTNETVERSION%%/libhostfxr.so
dotnet/metadata/workloads/%%BOOTSTRAP_SDKVERSION%%/userlocal
dotnet/packs/Microsoft.AspNetCore.App.Ref/%%FULL_DOTNETVERSION%%/analyzers/dotnet/cs/Microsoft.AspNetCore.App.Analyzers.dll
Expand Down

0 comments on commit 785055f

Please sign in to comment.