Skip to content

Commit

Permalink
Fixed install issue with libosrm_guidance
Browse files Browse the repository at this point in the history
  • Loading branch information
jdesgats committed Nov 15, 2019
1 parent b08f008 commit 9b752da
Show file tree
Hide file tree
Showing 3 changed files with 33 additions and 4 deletions.
4 changes: 3 additions & 1 deletion .SRCINFO
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
pkgbase = osrm-backend
pkgdesc = High performance routing engine written in C++14 designed to run on OpenStreetMap data.
pkgver = 5.22.0
pkgrel = 3
pkgrel = 4
url = http://map.project-osrm.org/
arch = x86_64
license = BSD
Expand All @@ -13,8 +13,10 @@ pkgbase = osrm-backend
depends = intel-tbb
source = osrm-backend-5.22.0.tar.gz::https://github.com/Project-OSRM/osrm-backend/archive/v5.22.0.tar.gz
source = fix-boost-fs.patch
source = fix-guidance-so.patch
sha256sums = df0987a04bcf65d74f9c4e18f34a01982bf3bb97aa47f9d86cfb8b35f17a6a55
sha256sums = 2c353e7e942df92091cf138f9c47135a74dc6f70bcad6897b118b312ca226ad6
sha256sums = 5866c256dcfd63806d696483e2b9ca9b74edb969697ba4ac3025948c892c1407

pkgname = osrm-backend

9 changes: 6 additions & 3 deletions PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -2,21 +2,24 @@

pkgname=osrm-backend
pkgver=5.22.0
pkgrel=3
pkgrel=4
pkgdesc="High performance routing engine written in C++14 designed to run on OpenStreetMap data."
url="http://map.project-osrm.org/"
depends=("expat" "boost-libs" "lua52" "intel-tbb")
makedepends=("cmake" "boost")
arch=('x86_64')
license=('BSD')
source=("$pkgname-$pkgver.tar.gz::https://github.com/Project-OSRM/osrm-backend/archive/v$pkgver.tar.gz"
"fix-boost-fs.patch")
"fix-boost-fs.patch"
"fix-guidance-so.patch")
sha256sums=("df0987a04bcf65d74f9c4e18f34a01982bf3bb97aa47f9d86cfb8b35f17a6a55"
"2c353e7e942df92091cf138f9c47135a74dc6f70bcad6897b118b312ca226ad6")
"2c353e7e942df92091cf138f9c47135a74dc6f70bcad6897b118b312ca226ad6"
"5866c256dcfd63806d696483e2b9ca9b74edb969697ba4ac3025948c892c1407")

prepare() {
cd "$pkgname-$pkgver"
patch --forward --strip=1 --input="${srcdir}/fix-boost-fs.patch"
patch --forward --strip=1 --input="${srcdir}/fix-guidance-so.patch"
}

build() {
Expand Down
24 changes: 24 additions & 0 deletions fix-guidance-so.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
commit 46ab931c648f89f8a92f9b8f389944934eb184c0
Author: Julien Desgats <julien@desgats.fr>
Date: Fri Nov 15 10:19:04 2019 +0000

fix: install the osrm_guidance library

In the case of a shared object compilation, the resulting binaries need
that library. It was not installed along the others, leading to failures
when running osrm-extract.

Fixes #5603

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 27abf3008..0b1aaf3ab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -778,6 +778,7 @@ install(TARGETS osrm_customize DESTINATION lib)
install(TARGETS osrm_update DESTINATION lib)
install(TARGETS osrm_contract DESTINATION lib)
install(TARGETS osrm_store DESTINATION lib)
+install(TARGETS osrm_guidance DESTINATION lib)


# Install profiles and support library to /usr/local/share/osrm/profiles by default

0 comments on commit 9b752da

Please sign in to comment.