File tree 1 file changed +4
-1
lines changed
1 file changed +4
-1
lines changed Original file line number Diff line number Diff line change @@ -32,6 +32,8 @@ include $(GO_INCLUDE_DIR)/golang-values.mk
32
32
#
33
33
# * Files in any 'testdata' directory
34
34
#
35
+ # * go.mod and go.sum, in any directory
36
+ #
35
37
# e.g. GO_PKG_INSTALL_EXTRA:=example.toml marshal_test.toml
36
38
#
37
39
#
@@ -155,12 +157,13 @@ define GoPackage/Build/Configure
155
157
if [ "$(GO_PKG_INSTALL_ALL ) " != 1 ]; then \
156
158
code=$$$$(echo "$$$$files" | grep '\.\(c\|cc\|cpp\|go\|h\|hh\|hpp\|proto\|s\ ) $$$$') ; \
157
159
testdata=$$$$(echo "$$$$files" | grep '\(^\|/\ ) testdata/') ; \
160
+ gomod=$$$$(echo "$$$$files" | grep '\(^\|/\ ) go\.\(mod\|sum\)$$$$') ; \
158
161
\
159
162
for pattern in $(GO_PKG_INSTALL_EXTRA ) ; do \
160
163
extra=$$$$(echo "$$$$extra"; echo "$$$$files" | grep "$$$$pattern" ) ; \
161
164
done ; \
162
165
\
163
- files=$$$$(echo "$$$$code"; echo "$$$$testdata"; echo "$$$$extra" ) ; \
166
+ files=$$$$(echo "$$$$code"; echo "$$$$testdata"; echo "$$$$gomod"; echo "$$$$ extra" ) ; \
164
167
files=$$$$(echo "$$$$files" | grep -v '^[[:space:]]*$$$$' | sort -u ) ; \
165
168
fi ; \
166
169
\
You can’t perform that action at this time.
0 commit comments