Skip to content

Commit 3934999

Browse files
committed
flake.nix: Drop systemAgnosticOutputs.nixosConfigurations
There was a TODO about removing them, and it caused issues now when we evaluated into them and got to parsing `system = null`. `makemake` has been moved into `eachDefaultSystemOutputs.nixosConfigurations`. Nixpkgs was then not happy with the way we were importing the system configuration for `makemake`, so adjust the entry point of our import until it's happy. - Errored out on us importing an entire config into the module system, so change it into a module - sops-nix was getting imported twice (it's in `default.nix`'s `extendedNixosModules` already), so drop the second import from `makemake`.
1 parent f95c250 commit 3934999

File tree

2 files changed

+7
-12
lines changed

2 files changed

+7
-12
lines changed

flake.nix

+5-7
Original file line numberDiff line numberDiff line change
@@ -102,12 +102,6 @@
102102

103103
# Finally, define the system-agnostic outputs.
104104
systemAgnosticOutputs = {
105-
nixosConfigurations =
106-
# TODO: remove these, noone will (or can even, realistically) use them
107-
mapAttrs (_: mkNixosSystem classic') rawExamples // {
108-
makemake = import ./infra/makemake { inherit inputs; };
109-
};
110-
111105
inherit nixosModules;
112106

113107
# Overlays a package set (e.g. Nixpkgs) with the packages defined in this flake.
@@ -141,6 +135,10 @@
141135
};
142136
in
143137
rec {
138+
nixosConfigurations = mapAttrs (_: mkNixosSystem classic) {
139+
makemake = import ./infra/makemake { inherit inputs; };
140+
};
141+
144142
packages = ngipkgs // {
145143
overview = import ./overview {
146144
inherit lib lib' self;
@@ -212,7 +210,7 @@
212210
nixfmt-rfc-style.enable = true;
213211
};
214212
};
215-
"infra/makemake" = toplevel self.nixosConfigurations.makemake;
213+
"infra/makemake" = toplevel self.nixosConfigurations.${system}.makemake;
216214
"infra/overview" = self.packages.${system}.overview;
217215
# fake derivation for flake check
218216
"infra/templates" = pkgs.writeText "dummy" (lib.strings.toJSON classic'.templates.project);

infra/makemake/default.nix

+2-5
Original file line numberDiff line numberDiff line change
@@ -1,12 +1,9 @@
11
{ inputs }:
2-
inputs.nixpkgs.lib.nixosSystem {
3-
system = "x86_64-linux";
4-
5-
modules = [
2+
{
3+
imports = [
64
# Setup both a master and a worker buildbot instance in this host
75
inputs.buildbot-nix.nixosModules.buildbot-master
86
inputs.buildbot-nix.nixosModules.buildbot-worker
9-
inputs.sops-nix.nixosModules.default
107
./configuration.nix
118
{ nix.nixPath = [ "nixpkgs=${inputs.nixpkgs}" ]; }
129
];

0 commit comments

Comments
 (0)