Skip to content

Commit 1e378ec

Browse files
author
taca
committed
Update ruby-http to 0.9.8.
## 0.9.8 (2015-09-29) * [#260](httprb/http#258): Fixed global timeout persisting time left across requests when reusing connections. ([@zanker][]) ## 0.9.7 (2015-09-19) * [#258](httprb/http#258): Unified strategy for handling exception-based and exceptionless non-blocking I/O. Fixes SSL support on JRuby 9000. ([@tarcieri][]) ## 0.9.6 (2015-09-06) * [#254](httprb/http#254): Removed use of an ActiveSupport specific method #present? ([@tarcieri][]) ## 0.9.5 (2015-09-06) * [#252](httprb/http#252): Fixed infinite hang/timeout when a request contained more than ~16,363 bytes. ([@zanker][]) ## 0.9.4 (2015-08-26) * Fixes regression when body streaming was failing on some URIs. See #246. (@zanker) * Fixes require timeout statements. See #243. (@ixti) ## 0.9.3 (2015-08-19) * Fixed request URI normalization. See #246. (@ixti) - Avoids query component normalization - Omits fragment component in headline ## 0.9.2 (2015-08-18) * Fixed exceptionless NIO EOF handling. (@zanker) ## 0.9.1 (2015-08-14) * Fix params special-chars escaping. See #246. (@ixti) ## 0.9.0 (2015-07-23) * Support for caching removed. See #240. (@tarcieri) * JRuby 9000 compatibility
1 parent 81f7832 commit 1e378ec

File tree

3 files changed

+8
-20
lines changed

3 files changed

+8
-20
lines changed

www/ruby-http/Makefile

+2-2
Original file line numberDiff line numberDiff line change
@@ -1,7 +1,7 @@
1-
# $NetBSD: Makefile,v 1.6 2015/06/11 16:51:04 taca Exp $
1+
# $NetBSD: Makefile,v 1.7 2015/10/04 13:49:30 taca Exp $
22
#
33

4-
DISTNAME= http-0.8.12
4+
DISTNAME= http-0.9.8
55
CATEGORIES= www
66

77
MAINTAINER= tsutsui@NetBSD.org

www/ruby-http/PLIST

+2-14
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,4 @@
1-
@comment $NetBSD: PLIST,v 1.6 2015/06/11 16:51:04 taca Exp $
1+
@comment $NetBSD: PLIST,v 1.7 2015/10/04 13:49:30 taca Exp $
22
${GEM_HOME}/cache/${GEM_NAME}.gem
33
${GEM_LIBDIR}/.coveralls.yml
44
${GEM_LIBDIR}/.gitignore
@@ -16,9 +16,6 @@ ${GEM_LIBDIR}/Rakefile
1616
${GEM_LIBDIR}/examples/parallel_requests_with_celluloid.rb
1717
${GEM_LIBDIR}/http.gemspec
1818
${GEM_LIBDIR}/lib/http.rb
19-
${GEM_LIBDIR}/lib/http/cache.rb
20-
${GEM_LIBDIR}/lib/http/cache/headers.rb
21-
${GEM_LIBDIR}/lib/http/cache/null_cache.rb
2219
${GEM_LIBDIR}/lib/http/chainable.rb
2320
${GEM_LIBDIR}/lib/http/client.rb
2421
${GEM_LIBDIR}/lib/http/connection.rb
@@ -33,24 +30,18 @@ ${GEM_LIBDIR}/lib/http/mime_type/json.rb
3330
${GEM_LIBDIR}/lib/http/options.rb
3431
${GEM_LIBDIR}/lib/http/redirector.rb
3532
${GEM_LIBDIR}/lib/http/request.rb
36-
${GEM_LIBDIR}/lib/http/request/caching.rb
3733
${GEM_LIBDIR}/lib/http/request/writer.rb
3834
${GEM_LIBDIR}/lib/http/response.rb
3935
${GEM_LIBDIR}/lib/http/response/body.rb
40-
${GEM_LIBDIR}/lib/http/response/caching.rb
41-
${GEM_LIBDIR}/lib/http/response/io_body.rb
4236
${GEM_LIBDIR}/lib/http/response/parser.rb
4337
${GEM_LIBDIR}/lib/http/response/status.rb
4438
${GEM_LIBDIR}/lib/http/response/status/reasons.rb
45-
${GEM_LIBDIR}/lib/http/response/string_body.rb
4639
${GEM_LIBDIR}/lib/http/timeout/global.rb
4740
${GEM_LIBDIR}/lib/http/timeout/null.rb
4841
${GEM_LIBDIR}/lib/http/timeout/per_operation.rb
4942
${GEM_LIBDIR}/lib/http/uri.rb
5043
${GEM_LIBDIR}/lib/http/version.rb
5144
${GEM_LIBDIR}/logo.png
52-
${GEM_LIBDIR}/spec/lib/http/cache/headers_spec.rb
53-
${GEM_LIBDIR}/spec/lib/http/cache_spec.rb
5445
${GEM_LIBDIR}/spec/lib/http/client_spec.rb
5546
${GEM_LIBDIR}/spec/lib/http/content_type_spec.rb
5647
${GEM_LIBDIR}/spec/lib/http/headers/mixin_spec.rb
@@ -64,16 +55,13 @@ ${GEM_LIBDIR}/spec/lib/http/options/new_spec.rb
6455
${GEM_LIBDIR}/spec/lib/http/options/proxy_spec.rb
6556
${GEM_LIBDIR}/spec/lib/http/options_spec.rb
6657
${GEM_LIBDIR}/spec/lib/http/redirector_spec.rb
67-
${GEM_LIBDIR}/spec/lib/http/request/caching_spec.rb
6858
${GEM_LIBDIR}/spec/lib/http/request/writer_spec.rb
6959
${GEM_LIBDIR}/spec/lib/http/request_spec.rb
7060
${GEM_LIBDIR}/spec/lib/http/response/body_spec.rb
71-
${GEM_LIBDIR}/spec/lib/http/response/caching_spec.rb
72-
${GEM_LIBDIR}/spec/lib/http/response/io_body_spec.rb
7361
${GEM_LIBDIR}/spec/lib/http/response/status_spec.rb
74-
${GEM_LIBDIR}/spec/lib/http/response/string_body_spec.rb
7562
${GEM_LIBDIR}/spec/lib/http/response_spec.rb
7663
${GEM_LIBDIR}/spec/lib/http_spec.rb
64+
${GEM_LIBDIR}/spec/regression_specs.rb
7765
${GEM_LIBDIR}/spec/spec_helper.rb
7866
${GEM_LIBDIR}/spec/support/black_hole.rb
7967
${GEM_LIBDIR}/spec/support/capture_warning.rb

www/ruby-http/distinfo

+4-4
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
1-
$NetBSD: distinfo,v 1.6 2015/06/11 16:51:04 taca Exp $
1+
$NetBSD: distinfo,v 1.7 2015/10/04 13:49:30 taca Exp $
22

3-
SHA1 (http-0.8.12.gem) = 6b8b3776c1810af96ce390335fbdeffa48e9e607
4-
RMD160 (http-0.8.12.gem) = ce779fd49826f43725d5a5481e0a282ccf35f3ea
5-
Size (http-0.8.12.gem) = 71168 bytes
3+
SHA1 (http-0.9.8.gem) = a0de8b20e9801926dc25f40dffe5108be322c3e8
4+
RMD160 (http-0.9.8.gem) = 5b6b7ebe1a168c2402112c2ed6d62b1996dded41
5+
Size (http-0.9.8.gem) = 66560 bytes

0 commit comments

Comments
 (0)