Skip to content

Commit 9dd1476

Browse files
committed
devel/libaura: Add SONAME to the installed library to make pkg register the provide
Reported by: pkg-devel exp-run
1 parent 6f19e5f commit 9dd1476

File tree

2 files changed

+12
-2
lines changed

2 files changed

+12
-2
lines changed

devel/libaura/Makefile

+1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,6 @@
11
PORTNAME= libaura
22
PORTVERSION= 3.1.20051222
3+
PORTREVISION= 1
34
CATEGORIES= devel
45
MASTER_SITES= LOCAL/philip
56

devel/libaura/files/patch-Makefile

+11-2
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
1-
--- Makefile.orig Tue Apr 18 12:32:27 2006
2-
+++ Makefile Tue Apr 18 12:56:00 2006
1+
--- Makefile.orig 2006-04-18 00:32:27 UTC
2+
+++ Makefile
33
@@ -1,9 +1,6 @@
44
# Makefile for libaura.
55
# $Id: Makefile,v 1.20 2005/08/26 22:44:37 cpressey Exp $
@@ -10,3 +10,12 @@
1010
LIB= aura
1111
LIB_VER=3
1212

13+
@@ -17,7 +14,7 @@ ${SONAME}: ${OBJS}
14+
all: ${SONAME} ${ANAME}
15+
16+
${SONAME}: ${OBJS}
17+
- ${CC} ${OBJS} -shared ${LDFLAGS} -o ${SONAME}
18+
+ ${CC} ${OBJS} -shared ${LDFLAGS} -Wl,-soname,${SONAME} -o ${SONAME}
19+
ln -sf ${SONAME} ${SOLINK}
20+
21+
${ANAME}: ${OBJS}

0 commit comments

Comments
 (0)