We read every piece of feedback, and take your input very seriously.
To see all available qualifiers, see our documentation.
1 parent 6f19e5f commit 9dd1476Copy full SHA for 9dd1476
devel/libaura/Makefile
@@ -1,5 +1,6 @@
1
PORTNAME= libaura
2
PORTVERSION= 3.1.20051222
3
+PORTREVISION= 1
4
CATEGORIES= devel
5
MASTER_SITES= LOCAL/philip
6
devel/libaura/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Apr 18 12:32:27 2006
-+++ Makefile Tue Apr 18 12:56:00 2006
+--- Makefile.orig 2006-04-18 00:32:27 UTC
++++ Makefile
@@ -1,9 +1,6 @@
# Makefile for libaura.
# $Id: Makefile,v 1.20 2005/08/26 22:44:37 cpressey Exp $
@@ -10,3 +10,12 @@
10
LIB= aura
11
LIB_VER=3
12
13
+@@ -17,7 +14,7 @@ ${SONAME}: ${OBJS}
14
+ all: ${SONAME} ${ANAME}
15
+
16
+ ${SONAME}: ${OBJS}
17
+- ${CC} ${OBJS} -shared ${LDFLAGS} -o ${SONAME}
18
++ ${CC} ${OBJS} -shared ${LDFLAGS} -Wl,-soname,${SONAME} -o ${SONAME}
19
+ ln -sf ${SONAME} ${SOLINK}
20
21
+ ${ANAME}: ${OBJS}
0 commit comments