Skip to content

Commit 4857bdd

Browse files
committed
wip: gitea: install page loads
1 parent 7e9856e commit 4857bdd

File tree

2 files changed

+21
-24
lines changed

2 files changed

+21
-24
lines changed

gitea-patch-makefile.patch

+10-1
Original file line numberDiff line numberDiff line change
@@ -1,7 +1,16 @@
11
diff --git a/Makefile b/Makefile
2-
index bf3d93d3c..b6f305270 100644
2+
index bf3d93d3c..48f056189 100644
33
--- a/Makefile
44
+++ b/Makefile
5+
@@ -17,7 +17,7 @@ else
6+
DIST := dist
7+
DIST_DIRS := $(DIST)/binaries $(DIST)/release
8+
IMPORT := code.gitea.io/gitea
9+
-export GO111MODULE=on
10+
+export GO111MODULE=off
11+
12+
GO ?= go
13+
SHASUM ?= shasum -a 256
514
@@ -93,7 +93,7 @@ LDFLAGS := $(LDFLAGS) -X "main.MakeVersion=$(MAKE_VERSION)" -X "main.Version=$(G
615

716
LINUX_ARCHS ?= linux/amd64,linux/386,linux/arm-5,linux/arm-6,linux/arm64

wip/gitea.scm

+11-23
Original file line numberDiff line numberDiff line change
@@ -660,7 +660,7 @@ transformations, and locale-specific text handling.")
660660
`(#:install-source? #f
661661
#:tests? #f ; Disable tests and start with some manual testing
662662
#:import-path "code.gitea.io/gitea"
663-
;#:build-flags (list "-tags bindata sqlite sqlite_unlock_notify")
663+
;#:build-flags (list "-tags 'bindata sqlite sqlite_unlock_notify'")
664664
#:phases
665665
(modify-phases %standard-phases
666666
(add-after 'patch-source-shebangs 'unpatch-example-shebangs
@@ -675,22 +675,11 @@ transformations, and locale-specific text handling.")
675675
(("#!/gnu/store/.*/bin/sh") "#!/bin/sh"))))
676676
(add-before 'build 'prepare-build
677677
(lambda _
678-
(setenv "TAGS" "bindata sqlite sqlite_unlock_notify")
679-
; ))
680-
;(replace 'build
681-
; (lambda _
682-
; (with-directory-excursion "src/code.gitea.io/gitea"
683-
; (substitute* "Makefile"
684-
; (("-mod=vendor") "")
685-
; (("go-check generate") "go-check")
686-
;(("(GO_DIRS := .) vendor(.*)" all first last)
687-
; (string-append first last "\n"))
688-
; )
689-
; (invoke "make" "build")
690-
; (invoke "make" "gitea")
691-
; (invoke "make" "install")
692-
; )
693-
))
678+
(setenv "TAGS" "bindata sqlite sqlite_unlock_notify")))
679+
(replace 'build
680+
(lambda _
681+
(with-directory-excursion "src/code.gitea.io/gitea"
682+
(invoke "make" "build"))))
694683
(replace 'check
695684
(lambda* (#:key tests? #:allow-other-keys)
696685
(when tests?
@@ -709,18 +698,17 @@ transformations, and locale-specific text handling.")
709698
(invoke "make" "test-mysql8")
710699
(invoke "make" "test-pgsql")
711700
))))
712-
;(replace 'install
713-
; (lambda _
714-
; (with-directory-excursion "src/code.gitea.io/gitea"
715-
; (invoke "make" "install"))))
701+
(replace 'install
702+
(lambda _
703+
(with-directory-excursion "src/code.gitea.io/gitea"
704+
(invoke "make" "install"))))
716705
(add-after 'install 'wrap-program
717706
(lambda* (#:key outputs inputs #:allow-other-keys)
718707
(let* ((out (assoc-ref outputs "out"))
719708
(bin (string-append out "/bin/gitea"))
720709
(git (assoc-ref inputs "git")))
721710
(wrap-program bin
722-
`("PATH" ":" prefix (,(string-append git "/bin")))))))
723-
)))
711+
`("PATH" ":" prefix (,(string-append git "/bin"))))))))))
724712
(native-inputs
725713
(list go-github-com-stretchr-testify
726714
node))

0 commit comments

Comments
 (0)